Investigating: Platform Performance Degradation

Incident Report for Cyber Guru

Resolved

Following the resource rebalancing, platform performance has stabilized and operations have returned to normal. We will continue to monitor to ensure stability.
Posted Dec 29, 2025 - 18:21 CET

Monitoring

Due to intense traffic on some learning objects, some users experienced slowdowns and errors on the platform. We have rebalanced resources to address the issue and are continuing to monitor.
Posted Dec 29, 2025 - 18:04 CET

Investigating

We are aware of potential degraded performance on the platform and in course delivery. We are currently investigating and working to resolve any identified issues. We will provide updates as soon as possible.
Posted Dec 29, 2025 - 17:14 CET
This incident affected: Cyber Guru App and Cyber Guru Awareness / Channel.